LebGeeks

A community for technology geeks in Lebanon.

You are not logged in.

#1 July 2

rolf
Member

VPN over 4G

I just ran a few tests, at this time (5 - 5:30 PM).

I am connected through a 4G LTE (Alfa) phone with wifi hotspot, on a Windows laptop.

Without VPN it is fast and responsive, speedtest is 50Mbps download, no complaint at all.

However I am unable to achieve acceptable performance through VPN. I tried the following:
- OpenVPN server in Silicon Valley and London with the Pritunl client on the laptop.
- NordVPN server in USA and France with the NordVPN client on the laptop.

The connection is too slow to even load the speedtest page.

When I disable tethering and use a VPN client and run tests on my mobile phone I can get up to 10Mbps download for the London VPN which is much slower than the 80Mbps that I can get through direct connection, but still acceptable speed for my use.

What are your experiences on the topic and do you know why there would be such a dramatic loss of performance?

Last edited by rolf (July 2)

Offline

#2 July 2

nuclearcat
Member

Re: VPN over 4G

Most likely MTU issue, check over internet how to solve it.

Offline

#3 July 2

rolf
Member

Re: VPN over 4G

nuclearcat wrote:

Most likely MTU issue, check over internet how to solve it.

Thank you. I had already optimized the buffer on my OpenVPN server (obviously, I can't do this for the NordVPN server). I checked the config and the optimization is gone for some reason.
I will also tweak the MTU/MSS.

Offline

#4 July 2

rolf
Member

Re: VPN over 4G

Well, I spent the last hour doing tests, and all I got is "LATENCY ERROR". I could only load speedtest.net 3 or 4 and the fastest I saw is 10Mbps.

Then I thought let's try to reboot into Linux.

Now the test works every time, no more errors. I removed all my tweaks and I get reach 24Mbps on my VPN and 35Mbps on NordVPN server.

So something wrong with Windows.

Eeek.

Offline

#5 July 3

elserge82
Member

Re: VPN over 4G

you tested openvpn using tcp or udp?

Offline

#6 July 3

rolf
Member

Re: VPN over 4G

I'm using UDP. I think there is something wrong with Windows.

Offline

Board footer