LebGeeks

A community for technology geeks in Lebanon.

You are not logged in.

#1 January 23

Kareem
Member

Ogero Double NAT ?

I am not really sure if it's a double NAT issue but I don't understand what's going on lately.

Few months ago, my WAN IP switched to private. Rebooting etc.. won't solve the issue.  Port forwarding doesn't help as my External IP is different than my WAN IP which is different than my network IP.

I called their support but they don't understand what I'm talking about; they replied with the usual " Taffeh w dawweh ba3ed 3ashr d2ayi2"

Any idea what to do in this situation ?

6fc75f980911ecc217261abacea99b95.png

Offline

#2 January 23

DNA
Member

Re: Ogero Double NAT ?

yea it"s a big problem honestly Ogero dont wanna provide public IPs to the router anymore this means that it is impossible to forward ports whatsoever i contacted them and even talked to Mr . kreidieh he said they wont be giving public Ips anymore even dynamic ones and they are moving to IPv6 only for end users which is horrible at this point.

Last edited by DNA (January 23)

Offline

#3 January 23

Kareem
Member

Re: Ogero Double NAT ?

DNA wrote:

yea it"s a big problem honestly Ogero dont wanna provide public IPs to the router anymore this means that it is impossible to forward ports whatsoever i contacted them and even talked to Mr . kreidieh he said they wont be giving public Ips anymore even dynamic ones and they are moving to IPv6 only for end users which is horrible at this point.

Moving to IPV6 seriously ? I don't see it happening before 5 years.

He told you for end users which means US ? or corporate accounts you mean?

Offline

#4 January 23

xazbrat
Member

Re: Ogero Double NAT ?

No clue on what to do---I just checked mine and it is 172.xx.xx.xx but I remember getting those IP's for a while and then it sort of went away.  Good luck--keep rebooting or try changing the modem and see if that helps.

Online

#5 January 23

potato
Member

Re: Ogero Double NAT ?

Your having the same problem i had a year ago. Port forwarding is blocked since as you said we dont have public ip. ipv6 is not a solution since we dont have a static ipv6 provided by ogero even if they gave us ipv6... we need a better solution

Offline

#6 January 23

Aly
Member

Re: Ogero Double NAT ?

I have Ogero and I checked my modem, at the moment the IP is 77.42.X.X, sometimes I do get a private IP  starting with 172 but I can still down / up the wan interface via telnet many times until I get a public IP again.

Offline

#7 January 23

Kareem
Member

Re: Ogero Double NAT ?

Ok So i put the modem in bridge mode, connected to the internet from my PC by setting up a PPPoE connection and it's the same result. Unbelievable.... no matter how much I try, I dont get a public IP.

45ae18303135ab730ccc0ceba805ebf0.png

There is no way I can reach my PC from outside the network !

Offline

#8 January 23

nuclearcat
Member

Re: Ogero Double NAT ?

ipv4 ips is over, you should switch to ipv6, if you want to access your computer.
It is not that Ogero want or don't want, it is just because ipv4 scarce resource.

Offline

#9 January 23

Kareem
Member

Re: Ogero Double NAT ?

nuclearcat wrote:

ipv4 ips is over, you should switch to ipv6, if you want to access your computer.
It is not that Ogero want or don't want, it is just because ipv4 scarce resource.

And how can I switch to IPv6 if my ISP won't assign me one ?

Offline

#10 January 23

nuclearcat
Member

Re: Ogero Double NAT ?

Kareem wrote:
nuclearcat wrote:

ipv4 ips is over, you should switch to ipv6, if you want to access your computer.
It is not that Ogero want or don't want, it is just because ipv4 scarce resource.

And how can I switch to IPv6 if my ISP won't assign me one ?

You can nag on their support :)
And, sure, you can use tunnel brokers, some give for end users.

Offline

#11 January 23

Kareem
Member

Re: Ogero Double NAT ?

nuclearcat wrote:
Kareem wrote:
nuclearcat wrote:

ipv4 ips is over, you should switch to ipv6, if you want to access your computer.
It is not that Ogero want or don't want, it is just because ipv4 scarce resource.

And how can I switch to IPv6 if my ISP won't assign me one ?

You can nag on their support :)
And, sure, you can use tunnel brokers, some give for end users.

They told me they don't support IPV6 yet. Not sure what to do in this siutation. Probably an SSL tunnel is my best bet.

Offline

#12 January 23

Kareem
Member

Re: Ogero Double NAT ?

potato wrote:

Your having the same problem i had a year ago. Port forwarding is blocked since as you said we dont have public ip. ipv6 is not a solution since we dont have a static ipv6 provided by ogero even if they gave us ipv6... we need a better solution

I've seen in one of your threads that you managed to run IPv6 with internet connection. Can you tell me how ? Support is not collaborating. Was there a special request to have this feature enabled?

Offline

#13 January 23

rolf
Member

Re: Ogero Double NAT ?

This sucks because with all we are paying for internet in this country they do things like this to spare a few dollars on us.
Have you looked into VPN options that would provide you with a real IP?
Maybe there are some other options where you pay a couple of bucks to have a tunnel?

Offline

#14 January 23

beezer
Member

Re: Ogero Double NAT ?

You can buy a static IP from them for approx. 15,000ll a month. I had that problem since day 1 of DSL.

Offline

#15 January 23

Kareem
Member

Re: Ogero Double NAT ?

beezer wrote:

You can buy a static IP from them for approx. 15,000ll a month. I had that problem since day 1 of DSL.

Can you provide a link where there advertise such service?

I'll give them a call tomorrow.

Offline

#16 January 23

beezer
Member

Re: Ogero Double NAT ?

I don't know if they advertise such a service, go to the Ogero DSL department and complain to one of the guys there, then he'll do it for you. The one guy I met here was pretty understanding and straightforward about it.

They can't afford to give everyone a real IP, that's why you always get those freaking captcha's to confirm sites when you're online here.

Offline

#17 January 25

wollyka
Member

Re: Ogero Double NAT ?

I had a DSL connection since the beginning from Cyberia then IDM, never once i got a real IP.. You were lucky all those years. Welcome to the Dark ages :(

Offline

#18 January 26

DNA
Member

Re: Ogero Double NAT ?

Kareem wrote:
DNA wrote:

yea it"s a big problem honestly Ogero dont wanna provide public IPs to the router anymore this means that it is impossible to forward ports whatsoever i contacted them and even talked to Mr . kreidieh he said they wont be giving public Ips anymore even dynamic ones and they are moving to IPv6 only for end users which is horrible at this point.

Moving to IPV6 seriously ? I don't see it happening before 5 years.

He told you for end users which means US ? or corporate accounts you mean?

Yea they are already giving /64 Ipv6 when you configure your router for for dual stack, already mentioned to them that Ipv6 is still 20% adopted worldwide we need Public IPv4 he said no IPv4 for "us" only for corporate accounts at this point

Offline

#19 January 26

potato
Member

Re: Ogero Double NAT ?

Kareem wrote:
potato wrote:

Your having the same problem i had a year ago. Port forwarding is blocked since as you said we dont have public ip. ipv6 is not a solution since we dont have a static ipv6 provided by ogero even if they gave us ipv6... we need a better solution

I've seen in one of your threads that you managed to run IPv6 with internet connection. Can you tell me how ? Support is not collaborating. Was there a special request to have this feature enabled?

All i did was enable ipv6 within the settings assuming it would work and it worked :/ however they only assign dynamic ipv6 even if you dont restart your router next day you will have different IP for whatever reason (as far as i remember) another problem is that the connection became unstable for whatever reason browsing, gaming, streaming would lag many times within a session in all of connected devices.

And finally my host apps are still in ipv4 and not compatible with ipv6 and doing some workaround would be hassle and not optimized.

So all i did was fall back to dynamic ipv4 and lag is solved and install google remote chrome desktop app and when i need any app i just login to my host. its all i can do.

If you want home automation you still need a static ip to have a direct connection with your devices. In my case i did many workarounds to have some direct connections (but still not satisfied) and some not important left with the above solution.

Offline

#20 January 26

Kareem
Member

Re: Ogero Double NAT ?

There's no way to overcome GCNAT even with VPN it's pain in the ass and what I did notice lately is that your external IP address does change even if your PPPoE connection didn't restart.

I'm currently testing reverse tunnel over SSH. Will post my findings.

Offline

#21 February 10

Elitism Guru
Member

Re: Ogero Double NAT ?

You could always go with L2TP and a manually setup European VPS. Supported by nearly every platform, even routers.
I'm using Arubacloud, 1$/mo for a server in Italy, latency with fast path is around 60-70ms to google.com, ~50ms to euro servers. (w/o 45ms)
My fear is that having a dedicated IP address makes it more prone for security breaches compared to a dynamic one, especially if the VPS/IP is billed to you. (e.g third party illegal activities on your could be a trouble) Not the most anonymous setup.
Works well here with no carrier NAT issues.

I used the following "auto" script: github(dot)com/hwdsl2/setup-ipsec-vpn

Last edited by Elitism Guru (February 10)

Offline

#22 February 11

elserge82
Member

Re: Ogero Double NAT ?

Elitism Guru wrote:

You could always go with L2TP and a manually setup European VPS. Supported by nearly every platform, even routers.
I'm using Arubacloud, 1$/mo for a server in Italy, latency with fast path is around 60-70ms to google.com, ~50ms to euro servers. (w/o 45ms)
My fear is that having a dedicated IP address makes it more prone for security breaches compared to a dynamic one, especially if the VPS/IP is billed to you. (e.g third party illegal activities on your could be a trouble) Not the most anonymous setup.
Works well here with no carrier NAT issues.

I used the following "auto" script: github(dot)com/hwdsl2/setup-ipsec-vpn

The price I found was 2.79 euro /month can you please pm me your plan's link?? thank you:)

Offline

Board footer