A community for technology geeks in Lebanon.

You are not logged in.

#1 July 28 2021


L2TP connection Problems

Hey Lebgeeks,

Basically I'm trying to connect to my work vpn from lebanon over a Ogero DSL connection. The VPN type is L2TP/Ipsec. I'm able to connect to both my work and home VPN server (ive cloned my work setup at home) through touch LTE and my neighbors internet, which is also some form of over the air setup.

Whenever I try to connect through the Ogero DSL with my Mac, I get L2TP-VPN server does not respond. Verbose logs appear to show:
Wed Jul 28 13:39:10 2021 : IPSec phase 2 established
Wed Jul 28 13:39:10 2021 : IPSec connection established
Wed Jul 28 13:39:10 2021 : L2TP sent SCCRQ
Wed Jul 28 13:39:30 2021 : L2TP cannot connect to the server

The modem/router setup at home is D-Link DSL-224, which honestly i truly hate. I've tried turning off the firewall and it doesn't seem to work. I've also tried to set it into bridge mode, but I'm not really sure I did it right.

I'm just posting this wondering, has anyone else faced similar problems? Or at least, does anyone have any suggestions for how I should begin debugging this issue

Thanks for reading


#2 July 29 2021


Re: L2TP connection Problems

I've had the same exact problem in my DSL-2888A. It turned out that despite the firewall being disabled, I still needed to activate IPSec deep within the advanced settings of the Firewall.

On my router it's:

Features > Firewall > Advanced > Advanced Settings... > IPSec (VPN)


Board footer